It is currently Mon Dec 09, 2019 9:47 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Please, keep discussions on topic and in the right forum. The start menu topics go into the Classic Start Menu forum, etc. This makes it easier for people to locate topics they are looking for.
If you get a satisfactory response to your question, please mark the topic as "solved". Click the green √ button in the bottom-right of the post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Dec 20, 2015 9:14 am 
Offline

Joined: Sun Dec 20, 2015 8:55 am
Posts: 3
Hi. I've just donate to this great piece of software - made the transition (at last) from XP a little easier :)

Using 4.1.0 under Win 7 Prof 64bit

I have a slight irritation which is not a CS problem but maybe CS could provide a solution and hopefully users here will know of a solution.

Situation: Not all apps when installed give you the option to provide a Start/Programs folder location for the short cuts. So they default to the root Start/Programs menu hierarchy. But I like to arrange my Start/Program folders by type (e.g. one for Audio-Visual, another for Communications). So I end up moving the apps short cuts:

e.g. Start/Programs/Microsoft Silverlight folder to Start/Programs/Audio-Visual/Microsoft Silverlight

Problem: Silverlight keeps recreating a new and duplicate Start/Programs/Microsoft Silverlight folder and short cuts.
This also happens with AMD Catalyst Control Centre.

Is there a way to tell these packages that the Start/Programs location has moved? e.g. is there a Registry setting?

If there is a setting somewhere then could Classic Shell update the setting when I move the folders?

Once again many thanks for a great little utility.

Alan


Attachments:
Classic Menu.jpg
Classic Menu.jpg [ 66.38 KiB | Viewed 3052 times ]
Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 20, 2015 9:19 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
These programs use the so-called self-repairing installers, which will try to recover any files that appear "deleted". Since you move the shortcut, it is no longer where the installer placed it so it recreates it. You can try hiding the folder instead of deleting it. Maybe that will fool the installer.


Top
 Profile  
Reply with quote  
PostPosted: Sun Dec 20, 2015 9:40 am 
Offline

Joined: Sun Dec 20, 2015 8:55 am
Posts: 3
Many thanks Ivo for a very fast response. Great suggestion.

I've now hidden the folder - I'll report back what happens over a few reboots/restarts

For those who want to try this:

Right click on the Start/Programs/sub folder and select Properties. Then tick the "Hidden" box and then OK


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Majestic-12 [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.