It is currently Sat Oct 20, 2018 8:33 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Please, keep discussions on topic and in the right forum. The start menu topics go into the Classic Start Menu forum, etc. This makes it easier for people to locate topics they are looking for.
If you get a satisfactory response to your question, please mark the topic as "solved". Click the green √ button in the bottom-right of the post.



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Thu Apr 13, 2017 1:23 pm 
Offline

Joined: Fri Apr 08, 2016 7:32 pm
Posts: 9
Recently I've noticed. that the context menu option for a folder "Open in new window" doesn't work as it used before. It opens new WE with focus on Navigation panel for the drive. But I doesn't open / expand to the folder itself. And now I have to navigate to it manually...

How to fix that?

Related "Classic Explorer" options:
Navigation Pane | Auto-navigate to the selected folder = Always

Also (and I think it's related), I used to start WE with AutoHotkey command:
Run,%A_WinDir%\Explorer.exe /e,d:\
That opened WE and expanded its left panel with folders on D:. Not anymore...

I'm using "Classic Shell" version 4.3.0 with registered mousefocus.dll (to put focus in new WE).


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 13, 2017 10:12 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5344
'Open in new window' is a Windows command and has nothing to do with Classic Shell.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 14, 2017 4:45 pm 
Offline

Joined: Fri Apr 08, 2016 7:32 pm
Posts: 9
Good to know that. But the reason why I'm asking question in this forum is - I see different (and related) behavior depending on Classic Shell options: "Navigation pane style | Auto-navigate to the selected folder".

Here is what I see if "Auto-navigate to the selected folder" is set to:
1. Default / When using the keyboard
Navigate: only correct drive, folder is not opened
Address bar: showing correct folder
Right panel: correct folder's content
2. Always
Navigate: only correct drive, folder is not opened
Address bar: correct drive only without path to folder
Right panel: root folders of the drive with focus on first folder in the path.

In the first case at least address bar indicates correct folder... Then I have manually go there by using Right arrow key pressing it multiple times.

I'd like to to have "Always" option (as it emulates WXP style of navigation), but it doesn't even allow me to navigate to the requested folder with Right arrow key (as in #1 case above).

It's weird. I saw it working well, and not it's not... Do you have any advice on re-registering some DLL (assuming it was somehow unregistered) or check some registry values to make it work?


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 14, 2017 10:27 pm 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5344
Try merging this into the Registry. If that doesn't work, I don't know.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Folder\shell\opennewwindow]
"OnlyInBrowserWindow"=""
"LaunchExplorerFlags"=dword:00000001
"MUIVerb"="@shell32.dll,-8517"
"MultiSelectModel"="Document"

[HKEY_CLASSES_ROOT\Folder\shell\opennewwindow\command]
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Sun Apr 16, 2017 2:53 pm 
Offline

Joined: Fri Apr 08, 2016 7:32 pm
Posts: 9
@Gaurav, hank you for looking at your registry settings. I've compared them to mine and those are exactly the same.

In attempt to fix the problem I've unregistered "mousefocus.dll" and set Classic Shell option "Settings | Navigation Pane | Auto-navigate to the selected folder" to "When using the keyboard".(as it allows to keep correct path to the folder to open in Address Bar).

Now to open new folder in new WE I have to do:
1. Right click on the folder (let say it's "C:\WINDOWS\System32\drivers\etc") in Navigation Pane and choose "Open in new window"
2. In new WE I have to press TAB 3 times to put focus on drive C:
3. Press Right Arrow 4 times to open destination folder...

Is it how you do it too? I remember a month ago I was able to accomplish the task just with p.1 (see above)...

I'd hate to uninstall CS and install it back in order to try to fix it.


Top
 Profile  
Reply with quote  
PostPosted: Sun Apr 16, 2017 3:26 pm 
Offline

Joined: Fri Apr 08, 2016 7:32 pm
Posts: 9
I've just found a thread on the Internet, discussing Classic Shell, and they suggested to Disable / Enable in IE 3 related add-ons: Classic Explorer Bar + Explorer BHO Class + ClassicIEBHO Class. I Disabled them (without rebooting computer) and the problem persisted. I guess it means, that the problem is somehow deeper and reinstalling Classic Shell may not help in this case.

BTW, what exactly the option "Auto-navigate to selected folder" suppose to do / change?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.