It is currently Mon Sep 01, 2014 4:26 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Before posting a bug report or a feature request, search the forum for an older post on the same topic. If you are reporting a crash, try capturing a crash dump. You can find instructions here: How to capture crash dumps



Post new topic Reply to topic  [ 21 posts ] 
Author Message
PostPosted: Sat Oct 19, 2013 5:37 am 
Offline

Joined: Sat Oct 19, 2013 5:31 am
Posts: 2
I upgraded to 8.1. I did a repair install of 4.0.0. It still did not start. I uninstalled classic shell. I rebooted. I downloaded again and installed. It still does not start up on boot-up.


Top
 Profile  
 
PostPosted: Sat Oct 19, 2013 6:07 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 2576
If the Start Menu isn't starting, then in Classic Start Menu settings, General Behavior tab (All Settings), check if "Start automatically for this user" is checked.

You can also create a shortcut to "C:\Program Files\Classic Shell\ClassicStartMenu.exe" and put it in your startup folder as a workaround.

_________________
I do the testing, some new feature ideas and UX/usability feedback for Classic Shell from 2009-present. :)


Top
 Profile  
 
PostPosted: Sat Oct 19, 2013 6:27 pm 
Offline

Joined: Sat Oct 19, 2013 5:31 am
Posts: 2
Start Automatically for this user was already checked.
I created the shortcut suggested and rebooted and now the classic shell started with the desktop.
I do thank you for your support, but hope that in the future it will work as it should.
Thank you.


Top
 Profile  
 
PostPosted: Sat Oct 19, 2013 7:18 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 2817
Few things you can try:
Disable your antivirus. It may be blocking the start menu.

Open an administrative command prompt and type "regsvr32 startmenuhelper64.dll" (for 32-bit Windows type "regsvr32 startmenuhelper32.dll")


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 12:24 am 
Offline

Joined: Sun Oct 20, 2013 12:17 am
Posts: 1
Sorry Ivo, I have the same problem, Classic Shell does not start automatically now that I have upgraded to Windows 8.1.

As a complete newbie to this level of interference with the computers workings, what does your previous instructions do? and does that need to be done each time the computer is started?

Thanks

Bill


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 1:23 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 2576
No they don't have to be done each time Windows starts. It's a helper DLL which starts the Start Menu at startup. Once it's registered it should work, if it doesn't then you can also place a shortcut to Start Menu in your startup folder to start it. It will start just as fast on 8.1. :)

_________________
I do the testing, some new feature ideas and UX/usability feedback for Classic Shell from 2009-present. :)


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 5:35 pm 
Offline
User avatar

Joined: Sun Oct 20, 2013 5:10 pm
Posts: 4
If only a single user account was created then if it is a local account (as opposed to it being a Microsoft account) and if it has no password assigned to it, Windows 8.1 will boot straight to desktop, and will do so regardless of whether the "Skip Metro screen" feature is ticked (on the "Windows 8.1 Settings" tab). This, AFAIK, is the only scenario in which the problem will occur.


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:06 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 2817
Are you saying that in this case Windows 8.1 will always go to the desktop and disregard the "Skip Metro screen" setting? Does it do the same even if "When I sign in or close all apps on a screen, go to the desktop instead of Start" is unchecked? The two settings are supposed to be doing the same thing.


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:27 pm 
Offline
User avatar

Joined: Sun Oct 20, 2013 5:10 pm
Posts: 4
OK scratch that. I forgot I had also applied the registry hack as explained in the tutorial linked below.
http://dottech.org/76495/how-to-automat ... ndows-boot

On my Win 8.1 desktop PC, which uses the registry hack, Classic Shell refuses to start automatically, even if "Start Automatically for this user" is ticked. However, on my Win 8.1 laptop, Classic Shell 4.0.0 does not have this problem.


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:35 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 2817
On Windows 8.1 you do not need a registry hack to boot to Desktop. They added a setting for that. Look for it in the Navigation tab in the properties. The "Skip Metro screen" setting of Classic Shell controls the same Windows setting.

Please remove the hack and report here if it helps with the start of Classic Shell.


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:45 pm 
Offline
User avatar

Joined: Sun Oct 20, 2013 5:10 pm
Posts: 4
Ivo wrote:
On Windows 8.1 you do not need a registry hack to boot to Desktop.

I know. I applied it 11 months ago, when I was still running Win 8.0.

Quote:
Please remove the hack and report here if it helps with the start of Classic Shell.

OK, I will. Hang on a sec. :)


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 7:16 pm 
Offline
User avatar

Joined: Sun Oct 20, 2013 5:10 pm
Posts: 4
It appears that the free upgrade to Win 8.1 from the Windows Store had already removed the registry hack all by itself. I just removed my shortcut from my Startup folder and updated Classic Shell to 4.0.2, then rebooted. Doing that has solved the problem for me. Thank you for saving my life... *AGAIN* ! :D


Top
 Profile  
 
PostPosted: Mon Oct 21, 2013 7:55 am 
Offline

Joined: Mon Oct 21, 2013 5:53 am
Posts: 5
After I upgraded to Windows 8.1 my computer refused to go directly to the desktop. I got the Metro-app panel again. After I checked the new Windows 8.1 option to switch to desktop, all is well again. But why do I need the Windows option? I would like to have Classic Shell back in control again!

By the way, my Windows boots a lot slower after the upgrade. It takes more time to enter my log-in screen. But I guess that's not a conflict caused by Classic Shell.


Top
 Profile  
 
PostPosted: Tue Oct 22, 2013 6:37 am 
Offline
User avatar

Joined: Sun Jan 06, 2013 1:44 pm
Posts: 735
I had slower boots for a while after upgrade to, but it seems to have cleared itself up, back to where it used to be


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 6:04 am 
Offline

Joined: Wed Oct 23, 2013 5:08 am
Posts: 2
Thanks for the information, I have the same problem and I'll try these ideas.

_________________
Regards, Alexandre of www.cimaware.com


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 1:42 pm 
Offline

Joined: Wed Aug 07, 2013 12:13 pm
Posts: 33
Just as a heads up. The 8.1 update causes massive HDD fragmentation and also shatters the registry into many pieces. My registry was in 45 pieces. I did a boot time defrag with Puran to fix that. Slower boot times which gradually improve could be due to fragmentation that the built in Windows defragger eventually alleviates as part of automatic optimization and maintenance. This feature is on by default but can take a few days to a week to be triggered. You can of course do a manual defrag and optimization but most third party defrag tools have more options and do a better job than the built in one.

_________________
HP 5215us Laptop, 1.8ghz AMD Turion64 single core CPU, Mobility Radeon Xpress 200M graphics, Windows 8.1 Pro, Comodo Internet Security 6.3


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 2:03 pm 
Offline
User avatar

Joined: Sun Jan 06, 2013 1:44 pm
Posts: 735
Im on an ssd, so the boot time fragmentation shouldnt be an issue for me (infact I think I read somewhere that fragmentation is actually a good thing on ssds, as it spreads the load more evenly


Top
 Profile  
 
PostPosted: Sun Nov 17, 2013 3:05 am 
Offline

Joined: Sun Nov 17, 2013 2:58 am
Posts: 1
GauravK wrote:
You can also create a shortcut to "C:\Program Files\Classic Shell\ClassicStartMenu.exe" and put it in your startup folder as a workaround.

As I had the same problem, I put ClassicStartMenu in my startup folder but now I tested

Ivo wrote:
Open an administrative command prompt and type "regsvr32 startmenuhelper64.dll" (for 32-bit Windows type "regsvr32 startmenuhelper32.dll")

It works - Thank you so much.:P :lol: :D


Top
 Profile  
 
PostPosted: Sun Feb 09, 2014 3:23 am 
Offline

Joined: Sun Feb 09, 2014 3:16 am
Posts: 2
I have a slightly different problem here, I updated to Windows 8.1 (Pro 64 bit), almost everything works fine, I skip Metro screen and start on Desktop directly, BUT I have active corners and standard windows start button, though I checked Options in Classic shell not to have these...
The funny thing is, once I open Classic Start Menu Settings, active corners are deactivated and I get the Classic Start Button :p

I tried:
Quote:
Open an administrative command prompt and type "regsvr32 startmenuhelper64.dll"


But I got an error:

Any ideas?


Top
 Profile  
 
PostPosted: Sun Feb 09, 2014 4:52 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 2576
Which version of Classic Shell are you using? Upgrade to Classic Shell 4.0.4.

_________________
I do the testing, some new feature ideas and UX/usability feedback for Classic Shell from 2009-present. :)


Top
 Profile  
 
PostPosted: Sun Feb 09, 2014 8:37 am 
Offline

Joined: Sun Feb 09, 2014 3:16 am
Posts: 2
Ah, I was using 4.0.2 somehow didn't get the usual reminder to update :)

I did an uninstall and a clean reinstall of 4.0.4 and it works now very nicely ;-)

Thank you very much!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2014, Ivo Beltchev.
All right reserved.