It is currently Sat Oct 20, 2018 4:18 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Before posting a bug report or a feature request, search the forum for an older post on the same topic. If you are reporting a crash, try capturing a crash dump. You can find instructions here: How to capture crash dumps



Post new topic Reply to topic  [ 69 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Wed Sep 27, 2017 6:31 am 
Offline

Joined: Wed Sep 27, 2017 6:29 am
Posts: 4
I've been having the issue with several Windows 10 1607 / CS 4.3.0 clients, updated to Windows 10 1703 / CS 4.3.1 and still have the same problem.
I would really like to get to the bottom of this issue, I've got a user that's UI is locking up every 30 minutes or so.

If you let me know what tools you want me to use to capture crash dumps or logs let me know all I'll get straight on it.


Top
 Profile  
Reply with quote  
PostPosted: Wed Sep 27, 2017 7:07 am 
Offline
User avatar

Joined: Thu Jan 03, 2013 12:38 am
Posts: 5344
How to capture crash dumps or slowdown dumps: viewtopic.php?f=12&t=6 There are different ways so if one doesn't work, try the alternative method.

_________________
Links to some general topics:

Compare Start Menus

Read the Search box usage guide.

I am a Windows enthusiast and helped a little with Classic Shell's testing and usability/UX feedback.


Top
 Profile  
Reply with quote  
PostPosted: Wed Sep 27, 2017 7:33 am 
Offline

Joined: Wed Sep 27, 2017 6:29 am
Posts: 4
I've uploaded the crash dumps from my machine to the MediaFire link in the above article, not sure if it will help though as these weren't captured when the freeze occurs.

Explorer didn't crash because of the thread issue though. That occurs randomly and is near impossible to re-create.

I've set up the Process Monitor on one of my clients having the issue and I am capturing all events for the Explorer.exe process and will upload the logs when it freezes up.


Top
 Profile  
Reply with quote  
PostPosted: Wed Sep 27, 2017 9:15 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
I don't see anything obvious in the dumps. The Classic Shell code is not doing anything at this time. There is some COM activity trying to communicate with another process, probably the UWP brokers.
I'm not saying Classic Shell is not the root cause, but at the time of the dump there is no evidence of that.


Top
 Profile  
Reply with quote  
PostPosted: Wed Sep 27, 2017 11:15 pm 
Offline

Joined: Wed Sep 27, 2017 6:29 am
Posts: 4
Computer crashed again last night, captured all explorer events throughout the day up until the crash (2.8M Events if you want to know) I'll trawl through them and get rid of the gumf and upload the rest.


Top
 Profile  
Reply with quote  
PostPosted: Thu Sep 28, 2017 4:18 am 
Offline

Joined: Wed Sep 27, 2017 6:29 am
Posts: 4
I've uploaded the logs from Process Monitor around the time of the crash.
Hopefully something sticks out.
Is it worth me running the ProcDump tool when Explorer is crashed?


Top
 Profile  
Reply with quote  
PostPosted: Thu Sep 28, 2017 9:43 am 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
I think running ProcDump after the fact will not work. If you want to save dump automatically without running ProcDump constantly, you need to use the registry method. The link is at the top of this page.


Top
 Profile  
Reply with quote  
PostPosted: Tue Oct 17, 2017 12:23 pm 
Offline

Joined: Tue Sep 05, 2017 5:38 am
Posts: 13
Anybody had a chance to test CS 4.3.1 with Windows 10 Fall Creators Update (released today)?


Top
 Profile  
Reply with quote  
PostPosted: Tue Oct 17, 2017 3:50 pm 
Offline
User avatar

Joined: Sun Jan 06, 2013 1:44 pm
Posts: 1949
No extensive testing Version 1709; but initially it seems to work for me; without needing to reinstall (it will prompt to 'reconfigure' classic shell)


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 15, 2017 7:26 am 
Offline

Joined: Mon May 16, 2016 2:34 am
Posts: 5
After much testing I found that the problem would on occasion show itself on non-domain machines, so there being something in a GPO causing it had to be unfortunately ruled out. Still no idea what the common thread is for the people that see it every now and then, but I'd rather explorer lock up occasionally than use the default Windows 10 start menu, and that sentiment is shared by the people that get the lockups (sorry Microsoft, you did a bad job there!).


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 9:49 am 
Offline

Joined: Mon Nov 20, 2017 9:36 am
Posts: 3
I'm also having this issue occasionally.
Currently still on Windows 10 1703.

The thing is I've noticed that frequently threads on the explorer.exe start to acumulate on waiting status until eventually the explorer process just locks up and crashes when enough "stuck" threads have accumulated.


Now, the thread that is common to all these ones that are stuck in waiting mode, is a thread belonging to ClassicStartMenu with a "Start address" reported sometimes as "ClassicStartMenuDLL.dll!DllExecuteNamedCommand", other times reported as "ClassicStartMenuDLL.dll!WaitDllInitThread", by Sysinternals Process Explorer.

I hope this helps in any way.


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 24, 2017 12:24 pm 
Offline
Site Admin
User avatar

Joined: Wed Jan 02, 2013 11:38 pm
Posts: 5333
So far the most reliable way to reproduce the issue has been to install some software. At some point during installation the threads in Explorer start piling up. There must be some weird interaction between Classic Shell, Explorer, and MSI.
I spent few days trying to track it down, but as of yet I have no good leads.


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 24, 2017 1:44 pm 
Offline

Joined: Mon Nov 20, 2017 9:36 am
Posts: 3
I've been able to reproduce the problem with some consistency, of explorer.exe accumulating waiting threads (which over time permanently increase the explorer.exe process memory usage and usually lead to the explorer crash) just by opening many explorer based windows (File Explorer, Control Panel, Devices and Printers, Default Programs, etc...) and then closing them.
In fact I've notested that the pile of stuck threads increases much more when closing the windows than when opening them.

By surprise of mine, I think I found a workaround.
I changed the File Explorer setting to "Launch folder windows in a separate process".
The end result is 2 explorer.exe processes running, but now I can open and close dozens of explorer based windows and both processes remain working normally with no waiting threads within both explorer processes.
And also both explorer.exe processes remain low on memory usage only increasing when the number windows increase and shrinking when I close the windows.

Now, I remember trying this exact same solution many months ago but it did not work out in the end like it did now.
So my guess is some change in the latest classicshell version makes this solution work.

The problem is, in windows 8 and 10 "Launch folder windows in a separate process" seems to have a problem of it's own, like File replace dialogs popping under instead of popping over the file explorer windows that launch them.
This as you may imagine is annoying as frequently while doing file copy/move operations, File Replace Dialogs go unnoticed for some time before they get attended.


Top
 Profile  
Reply with quote  
PostPosted: Mon Dec 11, 2017 4:10 pm 
Offline

Joined: Fri Jul 05, 2013 11:43 am
Posts: 3
FWIW - I was encountering this same issue (Explorer locking up all waiting on one thread; usually happened after resuming from sleep/from unlock). I rolled-back Classic Shell to 4.2.4 and so far the problem has not manifested itself


-mark
Edit 12-12: that didn't work. repro'd the issue again


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 21, 2017 11:05 pm 
Offline

Joined: Thu Dec 21, 2017 10:46 pm
Posts: 4
Hello everyone, i just created the account on the forum, first to say it's sad that the tool is no longer being supported/updated. It's been years of a magnificent job by Ivo, and just like many, i am one of those who thinks W10 looks horrible without CS.

With that being said, i am sorry in advance if this is the wrong thread, i have been browsing for quite a while, but to be honest i am not entirely sure my issue is the same commented here, but nothing to lose with asking, right?.

Here's the thing, and i'd like to point out that i am no computer expert. I was one of those "fortunate" people getting the Fall Creatores update getting shoved down my throat on day one without any warning or permission. Everything seemed to work just fine, even CS, which gave me the typical "updating" line, or adapting files or something, i don't remember, and it worked well. I HAD and i still HAVE CS 4.3.0-es installed.

A few days after FCU was installed, i had a full system lock up/freeze, that means that out of nowhere (browsing with chrome or firefox, maybe in steam, watching a movie or writing a note... anything really), the entire computer got frozen, the mouse wouldn't move, the keyboard wouldn't respond, the screen would remain the same, movie gets frozen, sound stops, and i couldn't even bring the tasks manager up (Cntrl+Alt+Del), nothing would respond, so i ended up having to reboot the computer the hard way (Reset). Everything worked fine after that, for DAYS, sometimes 10 days, sometimes 5, last couple of times it happened after 7 and 4 days respectively.

Since W10 "upgraded" to the FCU, 3 months ago?, 2 and a half?, i have been pointing fingers at many different things... updated graphics drivers, checked the state of the hard drives, tried different internet browsers, updated some other programs, etc... but nothing i do seems to be fixing the issue, and the main problem is that in order to find out if my "fixes" actually fix the issue, i have to wait days until it gets reproduced. Also i checked the entire event viewer since FCU was installed, and no error appears to be recorded at the times of the crashes (i noted down the times of the crashes and what i was doing at that time, but... didn't help).

So here is one of my last ideas to find out what the issue is, does Classic Shell have anything to do with this behaviour?, is my issue the same that is mentioned in this thread or other?. If so, is there a way to solve this?, even if the solution is to uninstall CS, seriously... it happens "only" once every few days, but it is really annoying, as a few times it "almost" killed hours of work (thankfully my browser did auto save most of it), and i am fearing it might eventually break something in the computer, as i have to manually reboot it with the reset button everytime it happens.

In any case, thanks in advance for anyone who can cast some light into this issue, and sorry if i missed some information in previous posts that would answer my question, as i said, my knowledge about computers is limited, and sometimes all i read sounds chinese to me :/

Hugs, thanks again!


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 22, 2017 3:36 am 
Offline
User avatar

Joined: Sun Jan 06, 2013 1:44 pm
Posts: 1949
It could potentially be related to classic shell, because classic shell hooks into explorer.. since it is something that happens occasionally, It would be hard indeed to nail down the culprit. but you could always uninstall classic shell for a few days, to see if the issue goes away (if it happens again, classic shell is probably not to blame and you can then re-install it)

Something else to consider is a full system reset, which is fairly straight forward on windows 10, so even a novice can do it (reinstallation is one of the few things windows 10 does right)
Make sure that all your files are backed up on another hardrive or flashdrive (only the C: drive gets wiped)


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 22, 2017 5:08 am 
Offline

Joined: Thu Dec 21, 2017 10:46 pm
Posts: 4
Thing is that according to what i've been reading here if i uninstall CS it might not work again, right?, so i wanted to avoid uninstalling it if it's not responsible. Plus what i am reading is that this lock ups/freezing people are having can be reverted by opening the tasks manager, but i cannot even access that when it happens, that's the detail that makes me doubt...

PS: I wouldn't even know how to start with that reinstall you mentioned... plus in the mind of someone like me it sounds like the end of times :P


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 22, 2017 5:51 am 
Offline
User avatar

Joined: Sun Jan 06, 2013 1:44 pm
Posts: 1949
I haven't heard of anyone lose classic shell completely after uninstalling it. you should be safe. I cant say the same about a system restore though, because a few people have had problems with 'fresh' copies of Windows 10 fall creators update


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 22, 2017 6:01 am 
Offline

Joined: Thu Dec 21, 2017 10:46 pm
Posts: 4
Alright, well, i might give it a go and uninstall it to see what happens. Downside is that even if it works i may have to wait two weeks till i feel in the clear... *sigh*. Still, it's better than nothing. If someone else has some similar experience to mine i would appreciate the comment, would help me feel that at least i'm on the right track :P.

In any case, thanks Jcee for the help :)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 69 posts ]  Go to page Previous  1, 2

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group, Almsamim WYSIWYG Classic Shell © 2010-2016, Ivo Beltchev.
All right reserved.